So, ich habe mal noch etwas "geforscht" und bin auf einige leicht verständliche Websites gestoßen:
http://www.was-ist-malware.de/allgemein/ip-spoofing/
http://de.ccm.net/contents/742-vortaeus ... g-spoofing
https://www.elektronik-kompendium.de/si ... 412101.htm
Best Practices sind darin auch beschrieben - und wurden nachfolgend verwendet.
Dann habe ich konfiguriert:
(Teilkonfiguration bezüglich Thema des Thread ohne Firewall. Routen mit Masken 240.0.0.0 lassen sich leider nicht konfigurieren. Dafür ACLs.)
Code: Alles auswählen
interface Null0
no ip unreachables
exit
ip route 0.0.0.0 255.0.0.0 Null0
ip route 10.0.0.0 255.0.0.0 Null0
ip route 100.64.0.0 255.192.0.0 Null0
ip route 127.0.0.0 255.0.0.0 Null0
ip route 169.254.0.0 255.255.0.0 Null0
ip route 172.16.0.0 255.240.0.0 Null0
ip route 192.0.0.0 255.255.255.0 Null0
ip route 192.0.2.0 255.255.255.0 Null0
ip route 192.168.0.0 255.255.0.0 Null0
ip route 198.18.0.0 255.254.0.0 Null0
ip route 198.51.100.0 255.255.255.0 Null0
ip route 203.0.113.0 255.255.255.0 Null0
ip access-list extended WAN-inbound
remark Bogon Networks mit Maske < 255.0.0.0: Null-Routen nicht konfigurierbar.
10 permit udp any eq bootps any eq bootpc
20 deny ip 224.0.0.0 15.255.255.255 any log
30 deny ip 240.0.0.0 15.255.255.255 any log
40 permit ip any any
exit
ip access-list extended WAN-outbound
remark Bogon Networks, Maske < 255.0.0.0: Null-Routen nicht konfigurierbar.
remark Nur valide Quelladressen nach NAT: WAN-Subnet vom WISP per DHCP
10 permit udp any eq bootpc any eq bootps
20 deny ip any 224.0.0.0 15.255.255.255 log
30 deny ip any 240.0.0.0 15.255.255.255 log
40 permit ip 192.168.xxx.xx 0.0.0.31 any
50 deny ip any any log
exit
interface GigabitEthernet8
description "Internet"
no ip dhcp client request domain-name
no ip dhcp client request dns-nameserver
ip dhcp client hostname none
ip dhcp client lease 365 0 0
ip address dhcp
ip access-group WAN-inbound in
ip access-group WAN-outbound out
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
ip verify unicast source reachable-via rx allow-default 101
zone-member security Internet
duplex auto
speed auto
no keepalive
no cdp enable
exit
Alles funktioniert bestens. Aufgrund Vorzuges speziellerer Routen (Most Match) ist ein Ausklammern intern verwendeter Netzwerke nicht notwendig. Selbst die Default-Route funktioniert noch.
Code: Alles auswählen
sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override
Gateway of last resort is 192.168.xxx.xx to network 0.0.0.0
S* 0.0.0.0/0 [254/0] via 192.168.xxx.xx
S 0.0.0.0/8 is directly connected, Null0
S 10.0.0.0/8 is directly connected, Null0
100.0.0.0/10 is subnetted, 1 subnets
S 100.64.0.0 is directly connected, Null0
S 127.0.0.0/8 is directly connected, Null0
S 169.254.0.0/16 is directly connected, Null0
S 172.16.0.0/12 is directly connected, Null0
172.25.0.0/16 is variably subnetted, 7 subnets, 2 masks
C 172.25.10.0/24 is directly connected, Vlan10
L 172.25.10.1/32 is directly connected, Vlan10
C 172.25.11.0/24 is directly connected, Vlan11
L 172.25.11.1/32 is directly connected, Vlan11
C 172.25.20.0/24 is directly connected, Vlan20
L 172.25.20.1/32 is directly connected, Vlan20
C 172.25.200.1/32 is directly connected, Loopback200
S 192.0.0.0/24 is directly connected, Null0
S 192.0.2.0/24 is directly connected, Null0
S 192.168.0.0/16 is directly connected, Null0
192.168.xxx.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.xxx.xx/xx is directly connected, GigabitEthernet8
L 192.168.xxx.xx/32 is directly connected, GigabitEthernet8
S 198.18.0.0/15 is directly connected, Null0
S 198.51.100.0/24 is directly connected, Null0
S 203.0.113.0/24 is directly connected, Null0
gw#
Ein traceroute zeigt keine Hops mehr mit vom WISP-Provider genutzten privaten Adressen. (WISP-Gateway ins öffentliche Netz mit NAT.) Das lokale CPE (Router-Modus) wird angezeigt, da direct connected (spezifische Route). Ping darauf möglich.
Persönliche Einschätzung:
Entsprechend der oben verlinkten Dokumente ist mein internes Netzwerk gegen IP-Spoofing und der Router an sich gegen DoS-Angriffe aus Bogon-Netzwerken geschützt. Damit auch gegen Angriffe aus dem Access-Netz des WISP. Der Router kommuniziert weder abgehend (Null-Routen) noch ankommend (uRPF-Check gegen Null-Routen) mit Bogon-Netzwerken.
Das Autosecure-Feature von Cisco konfiguriert entsprechend der "rausgepickten" Konfiguration, die ich im Eingangsbeitrag (Codeblock) gepostet habe. Vgl. a.
http://www.firewall.cx/cisco-technical- ... ature.html
Natürlich werden mit "Automatismen" keine Spezialfälle (WISP) berücksichtigt, nur IP-Spoofing des internen Netzes.
Bei Einsatz mehrerer Router und dynamischen Routingprotokollen mit Redistribution statischer oder asymmetrischen Routing zu mehreren ISPs wird es kompliziert, siehe Beitrag von @mludwig. Evtl. dedizierte(n) Firewall/Gateway nur mit statischem Routing.
Wer Lust/Paranoia hat, kann das Unicast Reverse Path Forwarding mit Null-Routen durch ACLs /
iptables mit Quelladressen in Richtung inbound ersetzen. Null-Routen (outbound) kann wohl jeder vernünftige Router und Linux. Nachteil ACLs: Performance geringer.
Empfohlene Best Practices in den Links sollte man ruhig mal lesen.
Sachlich editiert.